Performancing Metrics

WordPress 2.6.3 : Addressing a low risk vulnerability

This is not a mandatory update and no major risk or vulnerability were reported.  But WordPress recently announced version 2.6.3 saying :

A vulnerability in the Snoopy library was announced today.  WordPress uses Snoopy to fetch the feeds shown in the Dashboard.   Although this seems to be a low risk vulnerability for WordPress users, we wanted to get an update out immediately.  2.6.3 is available for download right now.

While this is an issue outside of the WordPress general system, it is an important update nonetheless.  It only affect two files and an option is given to download them to upload to your WordPress directories.  Here are the link to those files:

  1. wp-includes/class-snoopy.php
  2. wp-includes/version.php

The two files will patch the library file as well as update the WordPress version.  Or if you prefer to update fully… here’s the entire version available for download right here. 

(Yes, like you I had a “huh?” moment.  I didn’t know what the Snoopy library was.  This link cleared some things up for me, I hope it helps)

 

Categories: WordPress News

This post was written by . You can visit the for a short bio, more posts, and other information about the author.

Comment with Your Facebook Account

Comments