Performancing Metrics

WordPress 2.9 Brings Plugin Compatibility Check To Updater

With the release of WordPress 2.9 expected over the next weeks, it is time to dig a little deeper and discover new features. Since the translation string freeze no new features will be added anymore. Since some days I noticed on another blog where I run the latest nightly developer build, that the new plugin updater had integrated the WordPress.org plugin compatibility check we mentioned some here some weeks ago.

It seems now that this feature comes to your plugin updater within your blog.

WordPress 2.9 New Plugin Updater Functionalities

But that is not all. Another new and very handy function of WordPress 2.9 is that you have the possibility to upgrade all plugins at once.

WordPress 2.9 Plugin Upgrader

Both are nice additions to the built-in core updater of WordPress but sadly the new plugin compatibility check is not implemented platform wide yet.

plugin-installation-29

When you want to install a new plugin from within WordPress, the compatibility check still depends on the ‘Compatible up to:’ data provided by the plugin developer. Even though WordPress does send the version number of your blog installation as can be seen in the screenshot above.
From the built-in plugin updater I know that the Google XML Sitemap plugin works on WordPress 2.9 in 5 cases out of 6. The built-in plugin installer does not make any mention of this, even though the data is provided on the plugin page. It would be nice to see further integration.

Categories: WordPress News
Tags: , , , ,

This post was written by . You can visit the for a short bio, more posts, and other information about the author.

Comment with Your Facebook Account

Comments

Current ye@r *