<!DOCTYPE html>
<html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec"  xmlns:fb="http://www.facebook.com/2008/fbml" xmlns:og="http://opengraphprotocol.org/schema/">
<head >
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<title>7 Ways To Avoid Plugin Conflicts In WordPress | BloggingPro</title>

<!-- This site is optimized with the Yoast SEO plugin v12.4 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="One of the joys of customizing and running your own blog or website is the freedom to choose your own plugins. There are tons of them and plenty are even"/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://www.bloggingpro.com/archives/2019/11/06/ways-to-avoid-plugin-conflicts-in-wordpress/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="7 Ways To Avoid Plugin Conflicts In WordPress | BloggingPro" />
<meta property="og:description" content="One of the joys of customizing and running your own blog or website is the freedom to choose your own plugins. There are tons of them and plenty are even" />
<meta property="og:url" content="https://www.bloggingpro.com/archives/2019/11/06/ways-to-avoid-plugin-conflicts-in-wordpress/" />
<meta property="og:site_name" content="BloggingPro" />
<meta property="article:tag" content="WordPress issues" />
<meta property="article:tag" content="WordPress Plugins" />
<meta property="article:section" content="WordPress Tips" />
<meta property="article:published_time" content="2019-11-06T17:31:17+00:00" />
<meta property="og:image" content="https://www.bloggingpro.com/wp-content/uploads/2018/06/wordpress-development-2544896_1280.png" />
<meta property="og:image:secure_url" content="https://www.bloggingpro.com/wp-content/uploads/2018/06/wordpress-development-2544896_1280.png" />
<meta property="og:image:width" content="1280" />
<meta property="og:image:height" content="548" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.bloggingpro.com/#website","url":"https://www.bloggingpro.com/","name":"BloggingPro","potentialAction":{"@type":"SearchAction","target":"https://www.bloggingpro.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.bloggingpro.com/archives/2019/11/06/ways-to-avoid-plugin-conflicts-in-wordpress/#primaryimage","url":"https://www.bloggingpro.com/wp-content/uploads/2018/06/wordpress-development-2544896_1280.png","width":"1280","height":"548","caption":"Plugin Conflicts"},{"@type":"WebPage","@id":"https://www.bloggingpro.com/archives/2019/11/06/ways-to-avoid-plugin-conflicts-in-wordpress/#webpage","url":"https://www.bloggingpro.com/archives/2019/11/06/ways-to-avoid-plugin-conflicts-in-wordpress/","inLanguage":"en-US","name":"7 Ways To Avoid Plugin Conflicts In WordPress | BloggingPro","isPartOf":{"@id":"https://www.bloggingpro.com/#website"},"primaryImageOfPage":{"@id":"https://www.bloggingpro.com/archives/2019/11/06/ways-to-avoid-plugin-conflicts-in-wordpress/#primaryimage"},"datePublished":"2019-11-06T17:31:17+00:00","dateModified":"2019-11-06T17:31:17+00:00","author":{"@id":"https://www.bloggingpro.com/#/schema/person/a8b427fa5b7598e98144506710cbb997"},"description":"One of the joys of customizing and running your own blog or website is the freedom to choose your own plugins. There are tons of them and plenty are even"},{"@type":["Person"],"@id":"https://www.bloggingpro.com/#/schema/person/a8b427fa5b7598e98144506710cbb997","name":"Natividad Sidlangan","image":{"@type":"ImageObject","@id":"https://www.bloggingpro.com/#authorlogo","url":"https://secure.gravatar.com/avatar/cd4de3e5d10119d2c13b48751a75c833?s=96&d=wavatar&r=g","caption":"Natividad Sidlangan"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s7.addthis.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="BloggingPro &raquo; Feed" href="https://www.bloggingpro.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="BloggingPro &raquo; Comments Feed" href="https://www.bloggingpro.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="BloggingPro &raquo; 7 Ways To Avoid Plugin Conflicts In WordPress Comments Feed" href="https://www.bloggingpro.com/archives/2019/11/06/ways-to-avoid-plugin-conflicts-in-wordpress/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.bloggingpro.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.4"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='fbc_rc_widgets-style-css'  href='https://www.bloggingpro.com/wp-content/plugins/facebook-comments-for-wordpress/css/facebook-comments-widgets.css?ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='metro-pro-theme-css'  href='https://www.bloggingpro.com/wp-content/themes/bp-metro-pro-2017/style.css?ver=2.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.bloggingpro.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='bcct_style-css'  href='https://www.bloggingpro.com/wp-content/plugins/better-click-to-tweet/assets/css/styles.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='cptch_stylesheet-css'  href='https://www.bloggingpro.com/wp-content/plugins/captcha/css/front_end_style.css?ver=4.4.5' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.bloggingpro.com/wp-includes/css/dashicons.min.css?ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='cptch_desktop_style-css'  href='https://www.bloggingpro.com/wp-content/plugins/captcha/css/desktop_style.css?ver=4.4.5' type='text/css' media='all' />
<link rel='stylesheet' id='edd-styles-css'  href='https://www.bloggingpro.com/wp-content/plugins/easy-digital-downloads/templates/edd.min.css?ver=2.9.19' type='text/css' media='all' />
<link rel='stylesheet' id='guerrilla-author-box-css'  href='https://www.bloggingpro.com/wp-content/plugins/guerrillas-author-box/style.css?ver=20160209' type='text/css' media='all' />
<link rel='stylesheet' id='wpt-twitter-feed-css'  href='https://www.bloggingpro.com/wp-content/plugins/wp-to-twitter/css/twitter-feed.css?ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='google-font-css'  href='https://fonts.googleapis.com/css?family=Varela+Round%3A400&#038;ver=2.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='custom-css'  href='https://www.bloggingpro.com/wp-content/themes/bp-metro-pro-2017/css/custom.css?ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='addthis_all_pages-css'  href='https://www.bloggingpro.com/wp-content/plugins/addthis/frontend/build/addthis_wordpress_public.min.css?ver=5.2.4' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://www.bloggingpro.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.bloggingpro.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://www.bloggingpro.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.bloggingpro.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.bloggingpro.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.bloggingpro.com/?p=46410' />
<link rel="alternate" type="application/json+oembed" href="https://www.bloggingpro.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bloggingpro.com%2Farchives%2F2019%2F11%2F06%2Fways-to-avoid-plugin-conflicts-in-wordpress%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.bloggingpro.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bloggingpro.com%2Farchives%2F2019%2F11%2F06%2Fways-to-avoid-plugin-conflicts-in-wordpress%2F&#038;format=xml" />
<meta name="generator" content="Easy Digital Downloads v2.9.19" />
<meta property='og:title' content='7 Ways To Avoid Plugin Conflicts In WordPress' /><meta property='og:site_name' content='BloggingPro' /><meta property='og:url' content='https://www.bloggingpro.com/archives/2019/11/06/ways-to-avoid-plugin-conflicts-in-wordpress/' /><meta property='og:type' content='article' /><meta property='fb:app_id' content='162792183806745'>
<link rel="icon" href="https://www.bloggingpro.com/wp-content/themes/bp-metro-pro-2017/images/favicon.ico" />
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-4829570-2', 'auto');
  ga('send', 'pageview');

</script>

<meta name='ir-site-verification-token' value='1527725481' />

<meta name="google-site-verification" content="5Alo-CJPuBnqkve8gAcxwDVZCzh88ZQdNX4Wff5TNDo" />


<meta charset="utf-8" />

</head>
<body data-rsssl=1 class="post-template-default single single-post postid-46410 single-format-standard header-full-width content-sidebar genesis-breadcrumbs-hidden bp-metro-pro-theme-2017-update"><div class="site-container"><header class="site-header"><div class="wrap"><div class="title-area"><p class="site-title"><a href="https://www.bloggingpro.com" title="BloggingPro"><img class="site-logo" src="https://www.bloggingpro.com/wp-content/themes/bp-metro-pro-2017/images/logo.png" alt="BloggingPro logo"></a></p></div><nav class="nav-primary" aria-label="Main"><div class="wrap"><ul id="menu-main-menu" class="menu genesis-nav-menu menu-primary"><li id="menu-item-40026" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-40026"><a href="https://www.bloggingpro.com/blog/"><span >Blog</span></a></li>
<li id="menu-item-32370" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32370"><a href="https://www.bloggingpro.com/jobs/"><span >Blogging Jobs</span></a></li>
<li id="menu-item-32374" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32374"><a href="https://www.bloggingpro.com/contact/"><span >Contact</span></a></li>
<li id="menu-item-32379" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-32379"><a href="https://www.bloggingpro.com/archives/category/wordpress-tips/"><span >WordPress Tips</span></a></li>
<li id="menu-item-34433" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34433"><a href="https://www.bloggingpro.com/post-a-job/"><span >Post a Job</span></a></li>
<li id="menu-item-36772" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36772"><a href="https://www.bloggingpro.com/copywriting-blog-outreach-services/"><span >Services</span></a></li>
<li id="menu-item-39106" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39106"><a href="https://www.bloggingpro.com/blogging-books/"><span >Books for Bloggers</span></a></li>
<li id="menu-item-44149" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-44149"><a href="https://www.bloggingpro.com/feed/"><span >RSS Blog Feed</span></a></li>
<li id="menu-item-44150" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-44150"><a href="https://www.bloggingpro.com/jobs/feed/job_feed"><span >RSS Blogging Jobs Feed</span></a></li>
<li class="right search"><form class="search-form" method="get" action="https://www.bloggingpro.com/" role="search"><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="Search this website"><input class="search-form-submit" type="submit" value="Search"><meta content="https://www.bloggingpro.com/?s={s}"></form></li></ul></div></nav></div></header><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><article class="post-46410 post type-post status-publish format-standard has-post-thumbnail category-wordpress-tips tag-wordpress-issues tag-wordpress-plugins entry"><header class="entry-header"><h1 class="entry-title">7 Ways To Avoid Plugin Conflicts In WordPress</h1>
<p class="entry-meta"><time class="entry-time">11/6/2019</time> by <span class="entry-author"><a href="https://www.bloggingpro.com/archives/author/sid/" class="entry-author-link" rel="author"><span class="entry-author-name">Natividad Sidlangan</span></a></span> <span class="entry-comments-link"><a href="https://www.bloggingpro.com/archives/2019/11/06/ways-to-avoid-plugin-conflicts-in-wordpress/#respond">Leave a Comment</a></span> </p></header><div class="entry-content"><p><img width="585" height="250" src="https://www.bloggingpro.com/wp-content/uploads/2018/06/wordpress-development-2544896_1280-585x250.png" class="attachment-large size-large wp-post-image" alt="Plugin Conflicts" srcset="https://www.bloggingpro.com/wp-content/uploads/2018/06/wordpress-development-2544896_1280-585x250.png 585w, https://www.bloggingpro.com/wp-content/uploads/2018/06/wordpress-development-2544896_1280-280x120.png 280w, https://www.bloggingpro.com/wp-content/uploads/2018/06/wordpress-development-2544896_1280-768x329.png 768w, https://www.bloggingpro.com/wp-content/uploads/2018/06/wordpress-development-2544896_1280.png 1280w" sizes="(max-width: 585px) 100vw, 585px" /></p><div id="before-entry" class="before-entry widget-area"><section id="php_widget-3" class="widget php_widget"><div class="widget-wrap"><!-- BP below featured image -->

<a href="https://go.sumo.com/9926-0-1-11.html" target="_blank"><img style="border:0px" src="https://affiliate.sumo.com/media/banners/2Xyouremail2.png" width="300" height="250" alt=""></a>

</div></section>
</div><div class="at-above-post addthis_tool" data-url="https://www.bloggingpro.com/archives/2019/11/06/ways-to-avoid-plugin-conflicts-in-wordpress/"></div><p>One of the joys of customizing and running your own blog or website is the freedom to choose your own plugins. There are tons of them and plenty are even free, it&#8217;s like a digital buffet for WordPress. Of course, too much of anything can be bad and plugin conflicts are a thing you should certainly not ignore.</p>
<p><span id="more-46410"></span></p>
<p>Look, <a href="https://wordpress.org/plugins/" target="_blank" rel="noopener noreferrer">WordPress&#8217; plugin repository</a> may be an international buffet, but not all the food goes well with one another. One chef makes baby back ribs while the other makes salmon sushi and if they combine both in one plate, you&#8217;ll likely be asking for the manager. Okay, let&#8217;s drop the food analogy here since it&#8217;s making us hungry. What we&#8217;re saying is, each plugin developer codes their plugins differently and this can result in plugin conflict.</p>
<p>As with all conflicts and issues, however, prevention is better and less expensive than cure. Learning how to prevent plugin conflicts can save you a lot of time and effort in the future. So, we&#8217;ve made a list of things you can perform to save yourself a plugin-induced headache.</p>
<h2>Avoid installing outdated plugins</h2>
<p>As a rule of thumb, always remember to check if the plugin you want is still supported and is compatible with the latest WordPress version. WordPress usually tells you which is which and indicates just how outdated a specific plugin is.</p>
<p>There are instances where your installed plugins might become outdated without you knowing, however. That means you&#8217;ll eventually have to check in on them periodically. Every three months or so, you&#8217;ll want to go the WordPress plugin page of the plugin and see how long it has been since it was last updated. As long as it&#8217;s still compatible with the latest WordPress version, that should be good enough.</p>
<h2>Don&#8217;t install too many</h2>
<p>Now, you might get tempted to grab as many plugins as you can for each mundane task on your website but that might not be a good idea in hindsight. Apart from slowing down your website, it also increases the likelihood that of plugin conflicts on your website. This might be the case especially with unpopular plugins that don&#8217;t have thorough support compared to others.</p>
<p>In this case, less is more when it comes to installing plugins. The benefits of having plugins that you only need on an essential basis far outweigh an extravagant plugin library. Having way too many plugins than you need can also increase the likelihood that some of them have overlapping functions. That in itself can cause many conflicts as well once they start their specialized tasks.</p>
<h2>Update plugins individually</h2>
<p>This one could be a hassle and can be timeconsuming but it&#8217;s better than not knowing what&#8217;s wrong with your website after a mass plugin update. Updating your plugins one-by-one means you can check which of them is causing a conflict with another. You can then roll them or your whole website back to their previous functioning versions.</p>
<p><a href="https://bloggingpro.com/archives/2019/08/06/how-to-optimize-old-blog-posts-for-higher-search-traffic/update-blog-posts-with-new-information/" rel="attachment wp-att-45580"><img class="aligncenter wp-image-45580 size-large" src="https://bloggingpro.com/wp-content/uploads/2019/08/update-blog-posts-with-new-information-585x390.png" alt="update blog posts with new information" width="585" height="390" srcset="https://www.bloggingpro.com/wp-content/uploads/2019/08/update-blog-posts-with-new-information-585x390.png 585w, https://www.bloggingpro.com/wp-content/uploads/2019/08/update-blog-posts-with-new-information-280x187.png 280w, https://www.bloggingpro.com/wp-content/uploads/2019/08/update-blog-posts-with-new-information-768x512.png 768w, https://www.bloggingpro.com/wp-content/uploads/2019/08/update-blog-posts-with-new-information.png 1280w" sizes="(max-width: 585px) 100vw, 585px" /></a></p>
<p>So instead of using the button to automatically update everything, you might want to take your time instead and meticulously update each plugin. You don&#8217;t even have to do it every day, a weekly or monthly schedule could do and should save you the trouble of playing guesswork if ever a plugin or two suddenly stopped working or your whole website goes buggy.</p>
<h4>RELATED: <a href="https://bloggingpro.com/archives/2017/05/05/plugins-tools-to-make-blogging-easier/" target="_blank" rel="noopener noreferrer">Five Plugins and Tools to Make Blogging Easier</a></h4>
<h2>Check the plugins&#8217; support forums</h2>
<p>Each and every plugin in WordPress&#8217; plugin store actually displays how much the plugin users loved or hated the software. However, those five-star ratings don&#8217;t always show the full story. Some plugins could have a hidden or undiscovered incompatibility with others that only the users can unearth.</p>
<p>On the WordPress plugin page of the plugin, look for the &#8220;Support&#8221; tab. You&#8217;ll usually find a mini-forum in this tab with plenty of people discussing all the matters involving the plugin. Simply check for any conflict or problems with the plugin to see if the software is more trouble than it&#8217;s worth.</p>
<h2>Have a demo site</h2>
<p>Having a demo or staging website on your localhost is another great way to do a test run for any plugin you suspect might not be problem-free. Because if a plugin causes problems on the demo site, then chances are, your actual live site isn&#8217;t safe or exempted. A demo website is basically a clone of your actual website often installed in your computer&#8217;s hard drive.</p>
<p><a href="https://bloggingpro.com/archives/2019/08/09/best-cms-platform/choose-the-best-cms-platform-to-build-an-awesome-website/" rel="attachment wp-att-45591"><img class="aligncenter wp-image-45591 size-large" src="https://bloggingpro.com/wp-content/uploads/2019/08/Choose-the-Best-CMS-Platform-to-Build-an-Awesome-Website-585x390.jpg" alt="Choose the Best CMS Platform to Build an Awesome Website" width="585" height="390" srcset="https://www.bloggingpro.com/wp-content/uploads/2019/08/Choose-the-Best-CMS-Platform-to-Build-an-Awesome-Website-585x390.jpg 585w, https://www.bloggingpro.com/wp-content/uploads/2019/08/Choose-the-Best-CMS-Platform-to-Build-an-Awesome-Website-280x187.jpg 280w, https://www.bloggingpro.com/wp-content/uploads/2019/08/Choose-the-Best-CMS-Platform-to-Build-an-Awesome-Website-768x512.jpg 768w, https://www.bloggingpro.com/wp-content/uploads/2019/08/Choose-the-Best-CMS-Platform-to-Build-an-Awesome-Website.jpg 1280w" sizes="(max-width: 585px) 100vw, 585px" /></a></p>
<p>It may sound complicated but it can be as simple as installing a plugin. You can even install a demo or staging website through a plugin. That function typically comes bundled with backup or migration plugins and these can handle your demo site setup. Keep in mind that a demo or staging site has many uses other than testing plugins and having one goes a long way.</p>
<h2>Always have a backup of your website</h2>
<p>If you&#8217;ve installed a plugin that lets you do an easy demo site setup, then chances are, you already have <a href="https://bloggingpro.com/archives/2019/06/14/the-pros-and-cons-of-the-best-wordpress-backup-plugins/" target="_blank" rel="noopener noreferrer">a good backup plugin</a>. If you don&#8217;t want a plugin to handle the backups, you can always let dedicated software or other websites handle it for you. The bottom line, however, is that you always want a backup of a working phase of your website.</p>
<p>This way, if a plugin messes everything up and somehow causes a domino effect, you can always revert your website back to a time when it was working. Like demo sites, website backups, particularly the automatic ones, have many other functions that can save your website apart from rogue plugins.</p>
<h2>Do the same for themes</h2>
<p>Unsurprisingly, plugins not only come in conflict with each other but also with other aspects of WordPress. Sometimes it even causes problems with WordPress itself depending on the plugin. To that end, it can also cause problems with themes and vice versa. That&#8217;s why it&#8217;s important {(but not mandatory) to repeat the steps you did here for your themes.</p>
<p><a href="https://bloggingpro.com/archives/2019/07/06/checklist-before-purchase-premium-wp-theme/checklist-before-purchase-premium-wp-theme-2/" rel="attachment wp-att-45273"><img class="aligncenter wp-image-45273 size-large" src="https://bloggingpro.com/wp-content/uploads/2019/07/checklist-before-purchase-premium-wp-theme-585x346.jpg" alt="&lt;!--more--&gt;" width="585" height="346" srcset="https://www.bloggingpro.com/wp-content/uploads/2019/07/checklist-before-purchase-premium-wp-theme-585x346.jpg 585w, https://www.bloggingpro.com/wp-content/uploads/2019/07/checklist-before-purchase-premium-wp-theme-280x166.jpg 280w, https://www.bloggingpro.com/wp-content/uploads/2019/07/checklist-before-purchase-premium-wp-theme-768x454.jpg 768w, https://www.bloggingpro.com/wp-content/uploads/2019/07/checklist-before-purchase-premium-wp-theme.jpg 996w" sizes="(max-width: 585px) 100vw, 585px" /></a></p>
<p>This way, you can ensure good harmony between your themes and your plugins. Once you&#8217;ve crossed plugin conflicts out of your problem list for WordPress, you&#8217;ll be more productive and shift your focus on other aspects.</p>
<h4>RELATED: <a href="https://bloggingpro.com/archives/2015/12/14/7-amazing-wordpress-plugins-for-authors/" target="_blank" rel="noopener noreferrer">7 Amazing WordPress Plugins for Authors</a></h4>
<div class="guerrillawrap">
<div class="guerrillagravatar">
				<img alt='' src='https://secure.gravatar.com/avatar/cd4de3e5d10119d2c13b48751a75c833?s=80&#038;d=wavatar&#038;r=g' srcset='https://secure.gravatar.com/avatar/cd4de3e5d10119d2c13b48751a75c833?s=160&#038;d=wavatar&#038;r=g 2x' class='avatar avatar-80 photo' height='80' width='80' />
			</div>
<div class="guerrillatext">
<h4>Author: <span>Natividad Sidlangan</span></h4>
</p></div>
<div class="guerrillasocial"></div>
</p></div>
<!-- AddThis Advanced Settings above via filter on the_content --><!-- AddThis Advanced Settings below via filter on the_content --><!-- AddThis Advanced Settings generic via filter on the_content --><!-- AddThis Share Buttons above via filter on the_content --><!-- AddThis Share Buttons below via filter on the_content --><div class="at-below-post addthis_tool" data-url="https://www.bloggingpro.com/archives/2019/11/06/ways-to-avoid-plugin-conflicts-in-wordpress/"></div><!-- AddThis Share Buttons generic via filter on the_content --></div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://www.bloggingpro.com/archives/category/wordpress-tips/" rel="category tag">WordPress Tips</a></span> <span class="entry-tags">Tagged With: <a href="https://www.bloggingpro.com/archives/tag/wordpress-issues/" rel="tag">WordPress issues</a>, <a href="https://www.bloggingpro.com/archives/tag/wordpress-plugins/" rel="tag">WordPress Plugins</a></span></p><div class="after-entry widget-area"><div class="wrap"><section id="text-13" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Looking for flexible blogging and writing jobs?</h4>
			<div class="textwidget"><p><a href="http://flexjobsrocks.go2cloud.org/SHSF"> <img src="https://www.bloggingpro.com/wp-content/uploads/2017/11/flexjobs-842-fast.jpg"></a></p>
</div>
		</div></section>
</div></div></footer></article>
<!-- Facebook Comments for WordPress v3.1.3 by we8u (http://we8u.com/facebook-comments/) -->

<a name='facebook-comments'></a>

<div id='fb-root'></div>
<script src='https://connect.facebook.net/en_US/all.js#appId=162792183806745&amp;xfbml=1' type='text/javascript'></script>

<script type='text/javascript'>
	var addedComment = function(response) {
		//console.log('fbComments: Caught added comment');
		//console.log('fbComments:     Making AJAX call to update Facebook comment count');
		$.post('https://www.bloggingpro.com/wp-content/plugins/facebook-comments-for-wordpress/facebook-comments-ajax.php', { fn: 'addComment', xid: '_post46410' }, function(resp) {
			if (resp === 'true') {
				//console.log('fbComments:     Updated and cached Facebook comment count for post with xid=_post46410');
			} else {
				//console.log('fbComments:     FAILED to update Facebook comment count for post with xid=_post46410');
			}
		});

	};

	FB.Event.subscribe('comments.add', addedComment);
</script>

<div id='fbComments' style=''>
	<p style=''>Comment with Your Facebook Account</p>
<!-- facebook comments v2 only -->

	<fb:comments xid='_post46410' href='https://www.bloggingpro.com/archives/2019/11/06/ways-to-avoid-plugin-conflicts-in-wordpress/'  numposts='20' width='600' publish_feed='true' migrated='1'></fb:comments></div>
    <button id="commentary-toggle" class="hollow wide button" type="button">
        <span class="dashicons-admin-comments dashicons"></span>
        Show / Hide Comments
    </button>
    <div id="commentary">
    	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/archives/2019/11/06/ways-to-avoid-plugin-conflicts-in-wordpress/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://www.bloggingpro.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="cptch_block"><span class="cptch_title">Please prove you&#039;re human<span class="required"> *</span></span><span class="cptch_wrap cptch_math_actions">
				<label class="cptch_label" for="cptch_input_39"><span class="cptch_span">6</span>
					<span class="cptch_span">&nbsp;&#43;&nbsp;</span>
					<span class="cptch_span">5</span>
					<span class="cptch_span">&nbsp;=&nbsp;</span>
					<span class="cptch_span"><input id="cptch_input_39" class="cptch_input cptch_wp_comments" type="text" autocomplete="off" name="cptch_number" value="" maxlength="2" size="2" aria-required="true" required="required" style="margin-bottom:0;display:inline;font-size: 12px;width: 40px;" /></span>
					<input type="hidden" name="cptch_result" value="6APd" /><input type="hidden" name="cptch_time" value="1573146199" />
					<input type="hidden" name="cptch_form" value="wp_comments" />
				</label><span class="cptch_reload_button_wrap hide-if-no-js">
					<noscript>
						<style type="text/css">
							.hide-if-no-js {
								display: none !important;
							}
						</style>
					</noscript>
					<span class="cptch_reload_button dashicons dashicons-update"></span>
				</span></span></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='46410' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="8fe89b12cd" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="165"/></p>			</form>
			</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>    </div><!-- /#commentary -->
    </main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar"><section id="search-3" class="widget widget_search"><div class="widget-wrap"><form class="search-form" method="get" action="https://www.bloggingpro.com/" role="search"><input class="search-form-input" type="search" name="s" id="searchform-2" placeholder="Search this website"><input class="search-form-submit" type="submit" value="Search"><meta content="https://www.bloggingpro.com/?s={s}"></form></div></section>
<section id="text-12" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget">
<h2>Work for Bloggers</h2>

<ul><li><a href="http://flexjobsrocks.go2cloud.org/SHRj" rel="nofollow">Writing Jobs </a></li>
<li><a href="http://flexjobsrocks.go2cloud.org/SHRp" rel="nofollow">Online Content Jobs</a></li>
<li><a href="http://flexjobsrocks.go2cloud.org/SHRv" rel="nofollow">Editing Jobs </a></li>
<li><a href="http://flexjobsrocks.go2cloud.org/SHS1" rel="nofollow">Blogger Jobs</a></li>
<li><a href="http://flexjobsrocks.go2cloud.org/SHS7" rel="nofollow">Publishing Jobs</a></li>
<li><a href="http://flexjobsrocks.go2cloud.org/SHSD" rel="nofollow">Telecommuting and flexible jobs at Flexjobs</a></li></ul>
<!--is_category() || is_single() || is_page() || is_archive() || is_tag()--></div>
		</div></section>
<section id="text-11" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- BuySellAds Zone Code -->
<div id="bsap_1277791" class="bsarocks bsap_aee235f44ce624dacc5fcb422c4d4b67"></div>
<!-- End BuySellAds Zone Code -->
</div>
		</div></section>
<section id="text-14" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Blogging &#038; Writing Work</h4>
			<div class="textwidget"><ul>
<li><a href="http://flexjobsrocks.go2cloud.org/SHRj" rel="nofollow">Writing Jobs </a></li>
<li><a href="http://flexjobsrocks.go2cloud.org/SHRp" rel="nofollow">Online Content Jobs</a></li>
<li><a href="http://flexjobsrocks.go2cloud.org/SHRv" rel="nofollow">Editing Jobs </a></li>
<li><a href="http://flexjobsrocks.go2cloud.org/SHS1" rel="nofollow">Blogger Jobs</a></li>
<li><a href="http://flexjobsrocks.go2cloud.org/SHS7" rel="nofollow">Publishing Jobs</a></li>
<li><a href="http://flexjobsrocks.go2cloud.org/SHSD" rel="nofollow">Telecommuting and flexible jobs at Flexjobs</a></li>
</ul>
<p><!--is_category() || is_single() || is_page() || is_archive() || is_tag()--></p>
</div>
		</div></section>
</aside></div></div></div><footer class="site-footer"><div class="wrap"><p>BloggingPro &#x000A9;&nbsp;2019 Splashpress Media</p></div></footer><link href="//netdna.bootstrapcdn.com/font-awesome/4.5.0/css/font-awesome.css" rel="stylesheet" />
<!-- BuySellAds Ad Code --> <script type="text/javascript"> (function(){ var bsa = document.createElement('script'); bsa.type = 'text/javascript'; bsa.async = true; bsa.src = '//s3.buysellads.com/ac/bsa.js'; (document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(bsa); })(); </script> <!-- End BuySellAds Ad Code -->

<div class="AW-Form-679754600"></div>
<script type="text/javascript">(function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//forms.aweber.com/form/00/679754600.js";
    fjs.parentNode.insertBefore(js, fjs);
    }(document, "script", "aweber-wjs-v4jtint09"));
</script>

<script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.2.6"; } if (window.addthis_share === undefined) { window.addthis_share = {}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"ui_atversion":"300"}; } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.2.6","plugin_mode":"AddThis","anonymous_profile_id":"wp-c8536e6151595b08e730ff3544d8f79b","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());
                </script><script type='text/javascript'>
/* <![CDATA[ */
var edd_scripts = {"ajaxurl":"https:\/\/www.bloggingpro.com\/wp-admin\/admin-ajax.php","position_in_cart":"","has_purchase_links":"","already_in_cart_message":"You have already added this item to your cart","empty_cart_message":"Your cart is empty","loading":"Loading","select_option":"Please select an option","is_checkout":"0","default_gateway":"paypal","redirect_to_checkout":"0","checkout_page":"https:\/\/www.bloggingpro.com\/checkout-2\/","permalinks":"1","quantities_enabled":"","taxes_enabled":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.bloggingpro.com/wp-content/plugins/easy-digital-downloads/assets/js/edd-ajax.min.js?ver=2.9.19'></script>
<script type='text/javascript' src='https://www.bloggingpro.com/wp-includes/js/comment-reply.min.js?ver=5.2.4'></script>
<script type='text/javascript' src='https://www.bloggingpro.com/wp-content/themes/bp-metro-pro-2017/js/jquery.flexslider-min.js?ver=2.4.0'></script>
<script type='text/javascript' src='https://www.bloggingpro.com/wp-content/themes/bp-metro-pro-2017/js/responsive-menu.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://s7.addthis.com/js/300/addthis_widget.js?ver=1.0#pubid=ra-52f49abc748ddb56'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/waypoints/4.0.1/jquery.waypoints.min.js?ver=4.0.1'></script>
<script type='text/javascript' src='https://www.bloggingpro.com/wp-content/themes/bp-metro-pro-2017/js/bp-min.js?ver=1.0'></script>
<script type='text/javascript' src='https://s7.addthis.com/js/300/addthis_widget.js?ver=5.2.4#pubid=ra-5a61585fa15c0644'></script>
<script type='text/javascript' src='https://www.bloggingpro.com/wp-includes/js/wp-embed.min.js?ver=5.2.4'></script>
<script async="async" type='text/javascript' src='https://www.bloggingpro.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var cptch_vars = {"nonce":"b375d7a6ed","ajaxurl":"https:\/\/www.bloggingpro.com\/wp-admin\/admin-ajax.php","enlarge":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.bloggingpro.com/wp-content/plugins/captcha/js/front_end_script.js?ver=5.2.4'></script>
</body></html>

<!-- Dynamic page generated in 0.135 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2019-11-07 12:03:19 -->

<!-- super cache -->